[Stable Update] 2017-01-04 – Broadcom-wl, Brisk-menu, OpenVPN, Thunderbird

system_software_updateHello, Manjaro Community!

The year is still very young, yet we already have 2017’s first stable update waiting here for you:

Included is the first release of the brand new brisk-menu, developed for the Mate desktop by the Solus team.
Thunderbird received a security update by Mozilla, our realtime-kernel received its last update before we will upgrade its basekernel from linux48 to linux49.
Broadcom-wl driver, installer calamares, flightgear and some ruby packages were updated aswell as openVPN (!)


!! NOTICE !!

OpenVPN 2.4.0 update may require administrative interaction

The upgrade to openvpn 2.4.0 makes changes that are incompatible with
previous configuration. Take special care if you depend on VPN
connectivity for remote access! Administrative interaction is required:

– Configuration is expected in sub directories now. Move your files
from /etc/openvpn/ to /etc/openvpn/server/ or /etc/openvpn/client/.
– The plugin lookup path has changed. Remove extra plugins/ from relative
paths.
– The systemd unit openvpn@.service was replaced with
openvpn-client@.service and openvpn-server@.service. Restart and
reenable accordingly.

This does not affect the functionality of networkmanager, connman
or qopenvpn.


kind regards
Bernhard Landauer and the Manjaro development team


Package changes

  • core i686: 12 new and 12 removed packages
  • core x86_64: 12 new and 12 removed packages
  • extra i686: 113 new and 118 removed packages
  • extra x86_64: 113 new and 118 removed packages
  • community i686: 269 new and 246 removed packages
  • community x86_64: 286 new and 264 removed packages
  • multilib x86_64: 8 new and 11 removed packages

Current supported kernels

  • linux310 3.10.104
  • linux312 3.12.69
  • linux316 3.16.39
  • linux318 3.18.46
  • linux41 4.1.37
  • linux44 4.4.39
  • linux48 4.8.15
  • linux49 4.9.0
  • linux-RT-LTS 4.4.38_rt49
  • linux-RT 4.8.15_rt10

Links