Ninth Update-Pack available for Manjaro 0.8.7!

system_software_updateThis is our ninht update-pack for 0.8.7 series.

We updated linux34 to 3.4.68, linux310 to 3.10.18, linux311 to 3.10.7 and added finally linux312 with 3.12.0. KDE got updated to 4.11.3. For more information see here. Pamac gained AUR support. More information here.

Nvidia drivers are now at 331.20 and 304.116. If you have issues with the new nvidia driver, please try also nvidia-legacy or try to solve them as written in our wiki. Don’t do this update yet if you use 3rd-party kernels. Still waiting for an updated Catalyst release.

Current supported kernels:

  • Linux34 3.4.68 – our default kernel series for Manjaro 0.8.7
  • Linux38 3.8.13.12 – stable extended support kernel maintained by Canonical
  • Linux310 3.10.18 – it gets better with each update …
  • Linux311 3.11.7 – current stable release by Linus. AMD users should check out the new power support
  • Linux312 3.12.0 – the latest and greatest. Don’t use it yet …

Key-Updates:

  • KDE 4.11.3
  • Linux 3.4.68, 3.10.18, 3.11.7 & 3.12.0
  • pamac with AUR support
  • Nvidia 331.20 and 304.116

Changes in Detail:

  • community i686: 169 new and 163 removed package(s)
  • community x86_64: 169 new and 163 removed package(s)
  • core i686: 28 new and 25 removed package(s)
  • core x86_64: 28 new and 25 removed package(s)
  • extra i686: 547 new and 521 removed package(s)
  • extra x86_64: 543 new and 518 removed package(s)
  • multilib x86_64: 27 new and 23 removed package(s)

Update instructions:

Update your system as usual with pamac, octopi or pacman:

sudo pacman -Syu

Notice: You might have to wait until your mirror has synced.
Please check: http://repo.manjaro.org

Talk about this Update:

You can talk about this update-pack in our forum.


Tip: KDE 4.11 includes a reworked OpenGL 2 compositor. OpenGL 3.1 got introduced. By default OpenGL 2 with the fallback to OpenGL 1 is used. If the hardware doesn’t support OpenGL 3.1 it automatically falls back to OpenGL 2 or OpenGL 1. When running kwin_gles KDE defaults to OpenGL ES 3.0 if present otherwise OpenGL ES 2.0 is used. Catalyst Legacy seems to have issues with this change. Here is a workaround to get it working:

#!/bin/bash
export $(dbus-launch)
export KWIN_DIRECT_GL=1
export KWIN_COMPOSE=O2
kwin --replace &

Save it as a script and place it into your ~/.config/autostart dir. It is also possible to disable compositing till upstream fixes the bug.